package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:xxx|yyy)(,(?:xxx|yyy))*)$`)
var str = `xxx
yyy
xxx,xxx
yyy,xxx
xxx,yyy,yyy,yyy
But these would be invalid:
xx
yyyy
xxx,
xxxyyy
xxx,,yyy
,xxx,yyy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}