const regex = /^((?:xxx|yyy)(,(?:xxx|yyy))*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:xxx|yyy)(,(?:xxx|yyy))*)$', 'gm')
const str = `xxx
yyy
xxx,xxx
yyy,xxx
xxx,yyy,yyy,yyy
But these would be invalid:
xx
yyyy
xxx,
xxxyyy
xxx,,yyy
,xxx,yyy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}