import re
regex = re.compile(r"^((?:xxx|yyy)(,(?:xxx|yyy))*)$", flags=re.MULTILINE)
test_str = ("xxx\n"
"yyy\n"
"xxx,xxx\n"
"yyy,xxx\n"
"xxx,yyy,yyy,yyy\n"
"But these would be invalid:\n\n"
"xx\n"
"yyyy\n"
"xxx,\n"
"xxxyyy\n"
"xxx,,yyy\n"
",xxx,yyy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")