$re = '/^((?:xxx|yyy)(,(?:xxx|yyy))*)$/m';
$str = 'xxx
yyy
xxx,xxx
yyy,xxx
xxx,yyy,yyy,yyy
But these would be invalid:
xx
yyyy
xxx,
xxxyyy
xxx,,yyy
,xxx,yyy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);