// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:xxx|yyy)(,(?:xxx|yyy))*)$").unwrap();
let string = "xxx
yyy
xxx,xxx
yyy,xxx
xxx,yyy,yyy,yyy
But these would be invalid:
xx
yyyy
xxx,
xxxyyy
xxx,,yyy
,xxx,yyy";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}