import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:xxx|yyy)(,(?:xxx|yyy))*)$";
final String string = "xxx\n"
+ "yyy\n"
+ "xxx,xxx\n"
+ "yyy,xxx\n"
+ "xxx,yyy,yyy,yyy\n"
+ "But these would be invalid:\n\n"
+ "xx\n"
+ "yyyy\n"
+ "xxx,\n"
+ "xxxyyy\n"
+ "xxx,,yyy\n"
+ ",xxx,yyy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}