#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$"
Local $sString = "42.532" & @CRLF & _
"42536.123" & @CRLF & _
"23.5322" & @CRLF & _
"5326665344" & @CRLF & _
"2314435" & @CRLF & _
"5435" & @CRLF & _
"SHIT" & @CRLF & _
"12.42" & @CRLF & _
"42.5" & @CRLF & _
"153" & @CRLF & _
"ahefea" & @CRLF & _
"HELLO" & @CRLF & _
"fds" & @CRLF & _
"Hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")