package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$`)
var str = `42.532
42536.123
23.5322
5326665344
2314435
5435
SHIT
12.42
42.5
153
ahefea
HELLO
fds
Hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}