use strict;
my $str = '42.532
42536.123
23.5322
5326665344
2314435
5435
SHIT
12.42
42.5
153
ahefea
HELLO
fds
Hello';
my $regex = qr/^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}