re = /^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$/m
str = '42.532
42536.123
23.5322
5326665344
2314435
5435
SHIT
12.42
42.5
153
ahefea
HELLO
fds
Hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end