import re
regex = re.compile(r"^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$", flags=re.MULTILINE)
test_str = ("42.532\n"
"42536.123\n"
"23.5322\n"
"5326665344\n"
"2314435\n"
"5435\n"
"SHIT\n"
"12.42\n"
"42.5\n"
"153\n"
"ahefea\n"
"HELLO\n"
"fds\n"
"Hello")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")