using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$";
string input = @"42.532
42536.123
23.5322
5326665344
2314435
5435
SHIT
12.42
42.5
153
ahefea
HELLO
fds
Hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}