const regex = /^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\.[0-9]{3})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Z]+|[0-9]{1,9}|[0-9]{5}\\.[0-9]{3})$', 'mg')
const str = `42.532
42536.123
23.5322
5326665344
2314435
5435
SHIT
12.42
42.5
153
ahefea
HELLO
fds
Hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}