#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(cluster number (\d+)\n\n(\d+)\n\n(\d+)\n\n(\d+))"
Local $sString = "cluster number 1" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"" & @CRLF & _
"cluster number 2" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"" & @CRLF & _
"cluster number 3" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"" & @CRLF & _
"3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")