$re = '/(cluster number (\d+)\n\n(\d+)\n\n(\d+)\n\n(\d+))/';
$str = 'cluster number 1
1
2
3
cluster number 2
1
2
3
cluster number 3
1
2
3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);