// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(cluster number (\d+)\n\n(\d+)\n\n(\d+)\n\n(\d+))").unwrap();
let string = "cluster number 1
1
2
3
cluster number 2
1
2
3
cluster number 3
1
2
3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}