const regex = new RegExp('(cluster number (\\d+)\\n\\n(\\d+)\\n\\n(\\d+)\\n\\n(\\d+))', 'g')
const str = `cluster number 1
1
2
3
cluster number 2
1
2
3
cluster number 3
1
2
3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}