re = /(cluster number (\d+)\n\n(\d+)\n\n(\d+)\n\n(\d+))/
str = 'cluster number 1
1
2
3
cluster number 2
1
2
3
cluster number 3
1
2
3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end