using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(cluster number (\d+)\n\n(\d+)\n\n(\d+)\n\n(\d+))";
string input = @"cluster number 1
1
2
3
cluster number 2
1
2
3
cluster number 3
1
2
3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}