package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(cluster number (\d+)\n\n(\d+)\n\n(\d+)\n\n(\d+))`)
var str = `cluster number 1
1
2
3
cluster number 2
1
2
3
cluster number 3
1
2
3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}