#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<img [^>]*src="([^"]+)""
Local $sString = "<img src="http://google.com/q.jpeg"> matched" & @CRLF & _
"" & @CRLF & _
"<img alt="something" src="http://google.com/q.jpeg">" & @CRLF & _
"" & @CRLF & _
"<audio src="http://something..">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")