package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<img [^>]*src="([^"]+)"`)
var str = `<img src="http://google.com/q.jpeg"> matched
<img alt="something" src="http://google.com/q.jpeg">
<audio src="http://something..">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}