// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img [^>]*src="([^"]+)""#).unwrap();
let string = "<img src=\"http://google.com/q.jpeg\"> matched
<img alt=\"something\" src=\"http://google.com/q.jpeg\">
<audio src=\"http://something..\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}