$re = '/<img [^>]*src="([^"]+)"/m';
$str = '<img src="http://google.com/q.jpeg"> matched
<img alt="something" src="http://google.com/q.jpeg">
<audio src="http://something..">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);