re = /<img [^>]*src="([^"]+)"/m
str = '<img src="http://google.com/q.jpeg"> matched
<img alt="something" src="http://google.com/q.jpeg">
<audio src="http://something..">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end