import re
regex = re.compile(r"<img [^>]*src=\"([^\"]+)\"", flags=re.MULTILINE)
test_str = ("<img src=\"http://google.com/q.jpeg\"> matched\n\n"
"<img alt=\"something\" src=\"http://google.com/q.jpeg\">\n\n"
"<audio src=\"http://something..\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")