#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/sites\/Teams5\/(?<parent_site>[^\/]+)"
Local $sString = "/sites/Teams5/Nat_Man_MLP/ufbufuf " & @CRLF & _
"/sites/Teams5/connect-HRIS/ignig " & @CRLF & _
"/sites/Teams5/C-D/mhmòhm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")