re = /\/sites\/Teams5\/(?<parent_site>[^\/]+)/
str = '/sites/Teams5/Nat_Man_MLP/ufbufuf
/sites/Teams5/connect-HRIS/ignig
/sites/Teams5/C-D/mhmòhm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end