const regex = /\/sites\/Teams5\/(?<parent_site>[^\/]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/sites\\\/Teams5\\\/(?<parent_site>[^\\\/]+)', 'g')
const str = `/sites/Teams5/Nat_Man_MLP/ufbufuf
/sites/Teams5/connect-HRIS/ignig
/sites/Teams5/C-D/mhmòhm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}