using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/sites\/Teams5\/(?<parent_site>[^\/]+)";
string input = @"/sites/Teams5/Nat_Man_MLP/ufbufuf
/sites/Teams5/connect-HRIS/ignig
/sites/Teams5/C-D/mhmòhm";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}