package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/sites\/Teams5\/(?<parent_site>[^\/]+)`)
var str = `/sites/Teams5/Nat_Man_MLP/ufbufuf
/sites/Teams5/connect-HRIS/ignig
/sites/Teams5/C-D/mhmòhm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}