# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\#\[\d+\])\S*/$1something_else/gm;t' <<< "?[A7]DA<DA-SG
'[G7]G%SD\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
'[90]GA\\WTER"