const regex = /^(\#\[\d+\])\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\#\\[\\d+\\])\\S*', 'gm')
const str = `?[A7]DA<DA-SG
'[G7]G%SD\\\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
'[90]GA\\\\WTER`;
const subst = `$1something_else`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);