use strict;
my $str = '?[A7]DA<DA-SG
\'[G7]G%SD\\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
\'[90]GA\\\\WTER';
my $regex = qr/^(\#\[\d+\])\S*/mp;
my $subst = '$1something_else';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";