# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\#\[\d+\])\S*"
test_str = ("?[A7]DA<DA-SG\n"
"'[G7]G%SD\\$DF\n"
"#[27]F:./4FFF\n"
"?[P9]W3_2SS_F\n"
"'[90]GA\\\\WTER")
subst = "$1something_else"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.