// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\#\[\d+\])\S*").unwrap();
let string = "?[A7]DA<DA-SG
'[G7]G%SD\\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
'[90]GA\\\\WTER";
let substitution = "$1something_else";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}