package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\#\[\d+\])\S*`)
var str = `?[A7]DA<DA-SG
'[G7]G%SD\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
'[90]GA\\WTER`
var substitution = "$1something_else"
fmt.Println(re.ReplaceAllString(str, substitution))
}