#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\#\[\d+\])\S*"
Local $sString = "?[A7]DA<DA-SG" & @CRLF & _
"'[G7]G%SD\$DF" & @CRLF & _
"#[27]F:./4FFF" & @CRLF & _
"?[P9]W3_2SS_F" & @CRLF & _
"'[90]GA\\WTER"
Local $sSubst = "$1something_else"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)