# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\\"]+//gm;t' <<< "conn=\\"pass-\1001,ip-resolve-\10.10.10.10\\\"\""