$re = '/[\\\\"]+/m';
$str = 'conn=\\"pass-\\1001,ip-resolve-\\10.10.10.10\\\\""';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;