use strict;
my $str = 'conn=\\"pass-\\1001,ip-resolve-\\10.10.10.10\\\\""';
my $regex = qr/[\\"]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";