// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\\"]+"#).unwrap();
let string = "conn=\\\"pass-\\1001,ip-resolve-\\10.10.10.10\\\\\"\"";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}