re = /[\\"]+/m
str = 'conn=\\"pass-\\1001,ip-resolve-\\10.10.10.10\\\\""'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result