#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z0-9._&]+(?:/[A-Z0-9._&]+)+ - .*"
Local $sString = "ABC/DEF/003 - This is for testing" & @CRLF & _
"" & @CRLF & _
"XYZV/T&X/ABC/004 - This is for testing" & @CRLF & _
"" & @CRLF & _
"ZXC/004/007 - This is for testing" & @CRLF & _
"" & @CRLF & _
"This is testing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")