package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z0-9._&]+(?:/[A-Z0-9._&]+)+ - .*`)
var str = `ABC/DEF/003 - This is for testing
XYZV/T&X/ABC/004 - This is for testing
ZXC/004/007 - This is for testing
This is testing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}