$re = '`[A-Z0-9._&]+(?:/[A-Z0-9._&]+)+ - .*`m';
$str = 'ABC/DEF/003 - This is for testing
XYZV/T&X/ABC/004 - This is for testing
ZXC/004/007 - This is for testing
This is testing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);