re = /[A-Z0-9._&]+(?:\/[A-Z0-9._&]+)+ - .*/m
str = 'ABC/DEF/003 - This is for testing
XYZV/T&X/ABC/004 - This is for testing
ZXC/004/007 - This is for testing
This is testing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end