using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z0-9._&]+(?:/[A-Z0-9._&]+)+ - .*";
string input = @"ABC/DEF/003 - This is for testing
XYZV/T&X/ABC/004 - This is for testing
ZXC/004/007 - This is for testing
This is testing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}