import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z0-9._&]+(?:/[A-Z0-9._&]+)+ - .*";
final String string = "ABC/DEF/003 - This is for testing\n\n"
+ "XYZV/T&X/ABC/004 - This is for testing\n\n"
+ "ZXC/004/007 - This is for testing\n\n"
+ "This is testing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}