const regex = new RegExp('[A-Z0-9._&]+(?:/[A-Z0-9._&]+)+ - .*', 'gm')
const str = `ABC/DEF/003 - This is for testing
XYZV/T&X/ABC/004 - This is for testing
ZXC/004/007 - This is for testing
This is testing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}